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C H A P T E R

1
ABOUT NVIDIA QUADROVIEW

This chapter contains the following major topics:

� �What is NVIDIA QuadroView?� on page 1

� �Using QuadroView as a Stand-alone Viewer� on page 3

� �How the Customer Can View Files� on page 4

� �NVIDIA QuadroView as a Demo Viewer� on page 4

� �Using QuadroView as a CAD Viewer� on page 5

� �QuadroView as a Visualization Tool� on page 6

� �QuadroView Features and Benefits Summary� on page 7

What is NVIDIA QuadroView?
The NVIDIA QuadroView workstation application functions under Windows 
XP/2000 and Windows NT 4.0 in the following viewer modes: 

� OpenGL-based 3D viewer for the display and visualization of 3D models 
under AutoCAD and AutoCAD applications such as Autodesk Mechanical 
Desktop, Autodesk Architectural Desktop, and as a 

� Stand-alone viewer for off-line viewing, making it suitable for laptop 
presentations (Quadro2Go laptop) or viewing models by non-CAD 
designers, such as those who are decision makers in an organization.
1  C O N F I D E N T I A L N V I D I A  C o r p o r a t i o n
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NVIDIA QuadroView Modules
Figure 1.1 Examples of QuadroView Models

Viewer Module
The function of the viewer module (the main module) is to render 3D models 
using easy-to-use controls in real-time. The viewer utilizes the Open Inventor 
3D library, which is a scenegraph class library based on OpenGL. The models 
can be read from files, such as files using the VRML Internet (.wrl) or Open 
Inventor (.iv) file format or received through a communications link from 
another application. Models read from files do not need an active link to an 
application. For example, you can create and save your model on a CAD 
workstation. Then you only need the viewer and the saved files on a customer�s 
system for a presentation, as an example.

Communications Module
Communication modules set up the link to CAD applications. The link allows 
the application to send a model to the viewer and control it in real-time. The link 
works in the opposite direction as well; the viewer can send commands and data 
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to the application. The QV_C.ARX module for AutoCAD provides the link to 
AutoCAD and is part of the QuadroView installation software. 

ARX Module
The ARX (AutoCAD Runtime Extension) module is optionally installed by 
the QuadroView Setup program and registered for �Demand Loading� for all 
installed versions of AutoCAD. By default, the Demand Load setting is 
configured in so that QuadroView starts automatically when AutoCAD is 
started. 

Using the LoadConfig.exe configuration tool, you can modify the demand load 
(startup) functionality of QuadroView for each installed version of AutoCAD. 

Using QuadroView as a Stand-alone Viewer
Stand-alone viewer for off-line viewing, making it suitable for laptop 
presentations (Quadro2Go laptop) or viewing models by non-CAD designers, 
such as those who are decision makers in an organization.

Who Needs a Presentation?
� Decision makers (e.g. the boss of the drafter)
� Customers (Building Owner / Client)

� Demos

� Presentations

� Web Viewer --- Stereo 
for the Web
3  C O N F I D E N T I A L N V I D I A  C o r p o r a t i o n
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How the Customer Can View Files
QuadroView lets you create exports for the file types and media so that you do 
not have give the original drafting data to the customer.

NVIDIA QuadroView as a Demo Viewer
NVIDIA QuadroView can be used to run 

� Interactive demos

� Guided demos

at exhibitions, showrooms, and classes.

� Export / Generate 
following file types:

.avi, .wrl, .iv, .eps

� Different bitmap 
formats:

.bmp, .rgb, .tif, .jpg, etc.

� View it on a PC

� Burn it to a CD as VCD/
SVCD an play it on a 
DVD Player

� VCR

� Video recorder
N V I D I A  C o r p o r a t i o n  C O N F I D E N T I A L  4
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Using QuadroView as a CAD Viewer
You can use QuadroView while drafting in AutoCAD to:

� Find and prevent problems

� Perform fast visualizations

You can use QuadroView after drafting in AutoCAD to:

� Script a demo

� Create animation

� Prepare and give presentations

How NVIDIA QuadroView Can Locate and Prevent 
Problems 
For a complete overview of a scene or model, you can use QuadroView to:

� Render a complete scene 

� Render parts out of the a complex scene
Figure 1.2  Demonstration of a Cutting Plane (Gearing)

To find design problems, you can use QuadroView tools, such as:

� Cutting planes
� Grids
� Fly/Walk through 
5  C O N F I D E N T I A L N V I D I A  C o r p o r a t i o n
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Figure 1.3 Rendering Parts of a Complete Model: Example � Extract Details / Parts

Note: In Figure 1.3, notice that the AutoCAD rendering of the scene is still 
fuzzy and does not provide the clarity and detail-orientation provided by 
the QuadroView rendered scenes.

QuadroView as a Visualization Tool
As a �visualization tool�, QuadroView can 

� Display a virtual model for drafters 

� Display models in �stereo� using:

� Stereo glasses

AutoCAD

NVIDIA QuadroView
N V I D I A  C o r p o r a t i o n  C O N F I D E N T I A L  6
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� Stereo monitors

QuadroView provides a clear separation between �drafting� and �viewing� so 
that the same view port, monitor, or even the same PC is not shared for both 
drafting and viewing. 

Using QuadroView, you can use different materials, transparency, and so on to 
make the scene more realistic.
Figure 1.4 Examples of QuadroView as a Visual Tool 

QuadroView Features and Benefits Summary
� Create AVI presentations

� Easier viewing and navigation through scenes (e.g., Walk, Fly, and 
Examiner) compared to the default AutoCAD navigation 

� Do �virtual� walk-through of models; for example, an architect can design a 
building, export it to QuadroView, and give the data to a customer. The 
customer can �virtually� walk to the building and to determine if everything 
is to his/her liking.
7  C O N F I D E N T I A L N V I D I A  C o r p o r a t i o n
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� Save scenes in CAD-independent formats (.iv or .wrl), which can then be 
given to customers (decision makers) for their review without releasing your 
original drafting data. 

� While editing in AutoCAD, ability to rotate, zoom, pan, and examine the 
objects without changing your working view in AutoCAD

� Ability to work in Wireframe (AutoCAD) and at the same time view the 
model in shaded mode.

� View in Stereo mode and create Stereo presentations

� If you have a multi-monitor CAD workplace, you can run AutoCAD in full 
size on one monitor and the 3D viewer on the other monitor. So you can do 
your drafting job on one monitor and can see the result on the other monitor 
rendered in a nice 3D shaded view (without switching overlapping windows)

� Easily rotate, move, pan, and zoom your model in the viewer and send back 
the view to AutoCAD and can go on working in this new view with easier 
light source handling.

� Load different file formats such as .iv and .wrl and view them

� Show the animation contained in the CAD drawing 

� Easily change materials

� Use commands to automate tasks. For example, you can write a scrip or lisp 
program that performs a sample task such as: 
� Send the whole model

� Rotate it around the x axis

� Switch to Wireframe

� Rotate it again

� Switch back to Shaded mode, and so on.

Recent Features and Enhancements
� HTML Online Help

When you have any NVIDIA QuadroView application window open, press 
F1 to display online HTML Help, which provides detailed user information 
about the features. 

For additional information about online Help installation and access, see 
�Software Components� on page 32.

� Installation/Setup 
The Setup program lets you install QuadroView for several installed versions 
of AutoCAD on one computer. 
N V I D I A  C o r p o r a t i o n  C O N F I D E N T I A L  8
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� Preference Dialog Box 
The handling of options through the Preferences dialog box contains the 
following improvements: 

� The LoadConfig utility can be started through the Preferences dialog box 
in QuadroView.

� All sheets are visible, even when you are not linked to AutoCAD. 

� Mouse Wheel Support 
Mouse wheel support is available for navigation in Examiner, Fly, and Walk 
viewing modes.

� Global Environment Mapping 
When using the Global Environment Mapping (chrome effect) button in the 
Render toolbar, the model appears to be made of chrome and the 
environment mirrors on the surface. 

� Extended Full-Screen (Maximized) Render Area 
The full screen/maximized render area support lets you view the model in a 
maximized render window, which eliminates the need for menus or toolbars. 
If you maximize the QuadroView main window before using this mode, the 
model spans the entire screen without any toolbars. 

The full screen/maximized render area support also includes improved pop-
up menu choices in viewing modes, animation, cutting plane, stereo, etc. 

� Extended Stereo Support includes support for Shutter Glasses/
Quadbuffered Stereo

� Improved Animation Support
� Improved AVI Settings dialog box includes 1) Output Size combo box 

with selectable width, height, and image aspect ratio and 2) Frames per 
second (fps) support for frame based animation 

� Improved Animation Editor dialog box where you can manipulate the 
key frame settings and path settings 

� Animation formats in .iv (Open Inventor) and .dwg file formats 

� Animation Toolbar features improved handling and contains the 
following options: 

Go to start Stop Hide camera path
Go to end Select camera path Open Animation Editor
Play forward Select look At path Send animation data to AutoCAD
Play backward Show camera path Create AVI file
9  C O N F I D E N T I A L N V I D I A  C o r p o r a t i o n
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� New Animation Slider (visible if scene contains animation data) in the 
viewer window contains:

- Single step Forward and Backward option 

- Frame counter 
N V I D I A  C o r p o r a t i o n  C O N F I D E N T I A L  10
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C H A P T E R

2
OVERVIEW OF BASIC COMPONENTS

This chapter contains the following major topics:

� �User Interface� on page 12

� �Navigation Aids� on page 13

� �Viewer Modes� on page 13

� �Input Devices & Output Formats� on page 20

� �NVIDIA QuadroView Configuration� on page 21

� �How AutoCAD Link Works� on page 22

� �Animation� on page 24

� �Color and Material Editors� on page 27

Configuration Input/Output - Man/Machine

Different view 
modes

Link to CAD 
world

File Formats

Editors

Animation

DegradationCutting Planes

Grids
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User Interface
The user interface items labeled below are explained in various sections and 
chapters in this guide.
Figure 2.1 QuadroView Interface

QuadroView Menus

QuadroView Toolbars

Docking Area

Thumbwheels

Zoom scroll bar

QuadroView Viewer area

Open scene (file) in
QuadroView

Thumbwheels Animation Slider
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Navigation Aids

Viewer Modes
The following QuadroView viewing modes are 
discussed in this section:

� �Examiner Viewer� on page 14

� �Fly Viewer� on page 16

� �Walk Viewer� on page 17

Table 2.1 Navigation Aids

Thumbwheels and
Scroll Bars

Description

Mouse The mouse is an important tool in NVIDIA QuadroView and is used to move and 
shift the scene and/or the current camera. Specific manipulations are possible 
according to the active viewing mode, i.e, Examiner, Viewer, or Walk.

Thumbwheels To control the camera by using the thumbwheels (shown in �QuadroView Interface� 
on page 12), follow this procedure:
1. Position the mouse pointer in the central area of the thumbwheel.
2. Hold the left mouse button down and move the mouse in the appropriate direction.
The function of the wheels depends upon the selected viewing mode, i.e, Examiner, 
Viewer, or Walk.

3D Input Devices While using the Examiner navigation mode, you can move the scene with a 3D input 
device such as the LogiCAD Magellan 3D/Space Mouse or CyberPuck, or the Labtec 
SpaceController.

Animation Slider Note: The Animation Slider (shown in �QuadroView Interface� on page 12) on the 
viewer window is visible only if the scene contains animation data. 

You can use the animation slider to manipulate the frames and the forward & 
backward arrows to single step forward & backward. The frame counter counts 
forward & backward
13  N V I D I A  C o r p o r a t i o n
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Examiner Viewer 

The �Examiner� viewer allows free movement within three-dimensional space. 
The camera can be rotated about any desired axis around a central rotation 
point. The method of control is intuitive and matches an observer�s natural 
movements. For example, given that a sphere contains the scene and the center 
of the sphere is the rotation point. The analogy is that you simply need to place 
a hand on the surface of the sphere in order to move it. Any desired viewing 
direction is set in this manner.

The Examiner Viewer lets you �walk� through the scene. Figure 2.2 and Figure 
2.3 show sample scenes (.iv files) with Examiner Viewer mode enabled; the 
scene in Figure 2.3 also contains �animation� data, causing the Animation slider 
to appear.
Figure 2.2 Scene in Examiner Viewer Mode

Menu View > Examiner Viewer

Button on the Render Toolbar
N V I D I A  C o r p o r a t i o n  14
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Figure 2.3 Scene with Animation in Examiner Viewer Mode 

Table 2.2 Thumbwheels & Scroll Bars

Thumbwheels and
Scroll Bars

Description

Dolly The Dolly thumbwheel dollies (moves in and out of the scene) the 
camera. This function is camera tracking along the viewing axis. 
Note: If you are using a wheel mouse, you can use the mouse wheel 
to perform the same function.

Zoom The zoom slider adjusts the camera's field of view, measured in 
degrees.

Rotx The Rotx thumbwheel rotates the scene at the horizontal X-axis that 
is perpendicular to the viewing axis.

Roty The Roty thumbwheel rotates the scene at the vertical Y-axis that is 
perpendicular to the viewing axis.

Table 2.3 Additional Navigation Keys

Key Description
s Define rotation point.
ESC Toggles between Observe and Select modes.
ALT + mouse Temporary switches back to Observe mode.
Right mouse button Displays the pop-up menu for the Viewer.
Left mouse button Rotate the object around the rotation point. 
Center mouse button Move parallel to viewing plane (Pan).
Left + center mouse button Camera tracking (Dolly).

Table 2.4 Alternatives for Center Mouse Button
 Key Description
SHIFT + left mouse button Moves parallel to viewing plane (Pan).
CTRL + left mouse button Moves parallel to viewing plane (Pan).
15  N V I D I A  C o r p o r a t i o n



C H A P T E R  2 O v e r v i e w  o f  B a s i c  C o m p o n e n t s

BKNVRelQV_oem.book  Page 16  Friday, April 19, 2002  2:43 AM
Fly Viewer

Using the Fly Viewer option, you can fly freely through the scene in three-
dimensional space. A gauge displayed below the scene shows the current speed 
of the model. You can also fly backwards and stop!

Figure 2.4 shows a sample scene (an .iv file) with Fly Viewer mode enabled.
Figure 2.4 Scene in Fly Viewer Mode

CTRL + SHIFT + left mouse button Camera tracking (Dolly)

Table 2.5 Thumbwheels & Scroll Bars

Thumbwheels and
Scroll Bars

Description

Dolly The Dolly thumbwheel dollies (moves in and out of the scene) the 
camera. This function is camera tracking along the viewing axis. 
Note: If you are using a wheel mouse, you can use the mouse 
wheel to perform the same function.

Zoom The zoom slider adjusts the camera's field of view, measured in 
degrees.

Table 2.4 Alternatives for Center Mouse Button
 Key Description

Tip You can also use a 3D input device to perform these functions.

Menu View > Fly Viewer

Button on the Render Toolbar
N V I D I A  C o r p o r a t i o n  16
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Walk Viewer

The Walk Viewer lets you �walk� through the scene. Figure 2.5 and Figure 2.6 
show sample scenes (.iv files) with Walk Viewer mode enabled; the scene in 
Figure 2.6 contains �animation� data, causing the Animation slider to appear. 

Thumbwheels and
Scroll Bars

Description

Tilt The Tilt thumbwheel rotates the viewing direction up and down.
Pan The Pan thumbwheel rotates the scene in place.

Table 2.6 Additional Navigation Keys
Key Description
u Define the Up Vector of the scene.
s Define rotation point.
ESC Toggles between Observe and Select modes.
ALT + mouse Temporary switches back to Observe mode.
Right mouse button Displays the pop-up menu for the Viewer.
Left mouse button Increases speed.
CTRL + left mouse button Rotates viewing direction.
Center mouse button or 
SHIFT + left mouse button 

Decreases speed

Table 2.5 Thumbwheels & Scroll Bars (continued)

Menu View > Walk Viewer

Button on the Render Toolbar
17  N V I D I A  C o r p o r a t i o n



C H A P T E R  2 O v e r v i e w  o f  B a s i c  C o m p o n e n t s

BKNVRelQV_oem.book  Page 18  Friday, April 19, 2002  2:43 AM
Figure 2.5 Scene in Walk Viewer Mode

Figure 2.6 Scene with Animation Data in Walk Viewer Mode

Table 2.7 Thumbwheels and Scroll Bars
Key Description
Dolly The Dolly thumbwheel dollies (move in/out of the scene) the camera. This 

function is camera tracking along the viewing axis. 
Note: If you are using a wheel mouse, you can use the mouse wheel to perform the 
same function.

Zoom The zoom slider adjusts the camera's field of view, measured in degrees.
H The H thumbwheel displaces the scene vertically to �eye level�.
N V I D I A  C o r p o r a t i o n  18



N V I D I A  Q u a d r o V i e w  U s e r � s  G u i d e

BKNVRelQV_oem.book  Page 19  Friday, April 19, 2002  2:43 AM
Tilt The Tilt thumbwheel rotates the viewing direction up and down.
Pan The Pan thumbwheel rotates the scene in place.

Table 2.8 Additional Navigation Keys
Key Description
u Defines the Up Vector of the scene.
s Define rotation point.
ESC Toggles between Observe and Select modes.
ALT + mouse Temporarily switches back to Observe mode.
Right mouse 
button

Displays the popup context menu for the QuadroView viewer.

Left mouse 
button

Lets you walk around the scene. When you press the left mouse button, a box 
appears at the cursor position. Cursor movements above or below this box 
correspond to forward and backward movements. If you move the cursor to 
the left or right, you turn relative to the object. The speed is determined by 
the distance of the cursor from the box.

CTRL + left 
mouse button

Moves in the current viewing direction. Walking direction and viewing 
direction may be different.

Center mouse 
button or 
SHIFT + left 
mouse button

Rotates viewing direction. You can look up, as in looking at a ceiling, while 
you walk along a hallway.

Table 2.7 Thumbwheels and Scroll Bars
Key Description
19  N V I D I A  C o r p o r a t i o n
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Input Devices & Output Formats
NVIDIA QuadroView is pre-configured to 
work with the following 3D input devices 
when you are in QuadroView �Examiner 
Viewer� on page 14 mode.

Also see �3D Input Devices� on page 76 
and �3D Input Toolbar� on page 50.

� Mouse
� Keyboard
� 3D Devices

� Logitech LogiCad Magellan 3D/
Space Mouse, including CyberPuck

� Spacetec SpaceController

� 3D Output (Stereo)
� Anaglyph stereo

� Raw OpenGL

� Interlaced stereo

Using the Input/Output (I/O) Settings 
choices shown on the right, you can select 
from several different stereo formats. See 
�Preferences: I/O Settings� on page 76.

__________________________________

Using the Stereo Toolbar shown below 
(see �Stereo Toolbar� on page 55),

you can:

� Manipulate stereo offset, parallaxes, 
eyes, . . . . .

� Maximize view port to full screen
N V I D I A  C o r p o r a t i o n  20
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NVIDIA QuadroView Configuration

Configuration Tool

Common QuadroView and AutoCAD-linked Settings

The Demand Load Configuration 
dialog box is shown on the right. 
Using this dialog box, you can choose 
different AutoCAD installations with 
which to auto-load QuadroView. See 
�Loading QuadroView in AutoCAD� 
on page 38.

You can also access this dialog box 
from the QuadroView Preferences > 
AutoCAD Link dialog box. See 
Figure 8.4, �Preferences: AutoCAD 
Link� on page 81.

See �QuadroView Preferences Settings� on page 74 for details.

AutoCAD Tools

I/O SettingsAutoCAD Link

CommonSettings
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How AutoCAD Link Works

Figure 2.7 illustrates how AutoCAD link works. AutoCAD and QuadroView 
communicate through a memory buffer. To link QuadroView to AutoCAD, a 
plug-in module inside AutoCAD reads the AutoCAD database and 
communicates with QuadroView.
Figure 2.7 How AutoCAD Link Works

AutoCAD Links File Link

� AutoCAD

� Mechanical Desktop

� Architectural Desktop

� . . .

� For example, Pro Engineer, 3D Studio 
MAX, . . .. 

� Supported file formats include:

� VRML

� Open Inventor

AutoCAD

DB

File I/O

QuadroView

DB

File I/O

Communication
Port

OpenGL

Open
Inventor

Graphics Hardware

QuadroView  
Plug-in
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AutoCAD Link Modes

QuadroView File Link
Using QuadroView, you can link to any application that supports NVIDIA 
QuadroView file formats. Every change of the file will result in a reload of the 
entire file into QuadroView. 
Figure 2.8 How QuadroView File Link. Works

� Manual

� Auto (QuadroView Group)

� Auto (All)

� Auto (Active Part) - only 
Mechanical Desktop

For details on using these link 
modes, see �Preferences: 
AutoCAD Link� on page 80.

Q u ad ro V iew

D B

F ile  I/O
O p en G L

O p en
In ven to r

A p p licatio n X
Pro E, 3D  S tu d io  M A X ...

F ile  I/O
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F ileW atch
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File Formats for File Link Modes
� Open Inventor

� VRML 1.0

� VRML 97

Note: Currently, NVIDIA QuadroView does not support the entire VRML 
standard.

Figure 2.9 Sample VRML (.wrl) file

Animation
Key benefits of using the Animation feature include:
� Creation of animations for presentations 
� Quick and easy usage of the new animation data without having to delve into 

into the details; e.g., tangential camera movement, and so on.
� �Power user� features such as:

� Key table to control the different frames
� LookAt path for complex camera movements

� Saving of animation to .avi files in a variety of compression formats, based 
on the installed encoders on the computer.

� Saving of animation data to .dwg, .dxf, and .iv formats.
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You can use many Animation options with toolbars available in QuadroView 
and AutoCAD:
QuadroView Animation Options (AutoCAD) 

Animation Toolbar in QuadroView

Note: Also see �QuadroView Toolbar Options in AutoCAD� on page 86, 
�Animation Toolbar� on page 50.

More About Animation
The Camera Animation feature in NVIDIA QuadroView allows you to easily 
create virtual Walk-throughs and Fly-throughs of the current scene in two 
modes: simple and complex.
Figure 2.10 Scene with Animation 

Simple mode: You can draw a simple spline in the AutoCAD drawing and 
declare this spline as the Camera Path. This means the camera moves 
tangentially along this spline when playing the animation. (See Figure 2.12.)

Complex mode: You can improve this animation sequence by drawing a 
second spline and declaring it as the LookAt Path. The LookAt Path is the target 
path of the camera. While moving on the Camera Path, the direction of the 
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camera points to the corresponding target on the LookAt Path. (See Figure 
2.12.)

You also can fine-tune the animation by using the Animation Editor (Figure 
2.11), which allows you to define special keys and place them on the paths. A 
key defines the place on the Camera Path, the target on the LookAt Path, the 
Timestamp, and the Twist of the camera. Using the Animation Editor, you can 
also:

� Control the time frames

� Set the �World Up� direction

� Switch to �Loop Mode�

� Turn on real-time rendering

� Define the frame rate

For further information, see also �Animation Editor� on page 60.
Figure 2.11 Animation Editor 

Figure 2.12 Simple Mode: Camera Path (Tangential Camera Animation)
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Figure 2.13 Complex Mode: Camera and LookAt Path

Tips
� You can declare a spline as a path using any one of these methods: 

Animation Toolbar buttons, pop-up menu while a spline is selected in 
QuadroView, or Animation commands in AutoCAD. 

� To prevent the viewer from seeing the paths while animating, or for further 
work, you can hide the paths by using the appropriate Animation Toolbar 
buttons, the equivalent options in the Camera > Animation submenu, or the 
Animation commands in AutoCAD.

� To change the position of a key marker on one of the paths, you can move the 
marker only between the two boundary markers of the enclosing interval.

Note: You cannot overlap intervals.

� The Animation data is saved in the .DWG file of AutoCAD (if you have 
updated the data in AutoCAD using the Update button) and in the .IV file of 
QuadroView, so you can reload and replay it later.

� You also can generate an .AVI file and distribute it over the Internet, send it 
by e-mail, or burn it to a CD as VCD/SVCD (VideoCD/Super VideoCD) and 
play it on a DVD player.

Color and Material Editors
Using the �Background Color Editor� on page 62 and �Material Editor� on 
page 65 dialog boxes, you can:

Camera
Path 
A
B
C

LookAt
Path 
A�
B�
C�

Time

0
15
30

Twists

0
0
0

B and B� are corresponding points; one on 
the Camera Path and one on the LookAt 
Path. The animation must reach this key 
after 15 seconds. There is no rotation 
around the viewing axis.
27  N V I D I A  C o r p o r a t i o n



C H A P T E R  2 O v e r v i e w  o f  B a s i c  C o m p o n e n t s

BKNVRelQV_oem.book  Page 28  Friday, April 19, 2002  2:43 AM
� Assign materials to objects

� Define and manipulate materials

� Create different material palettes and select from them
Figure 2.14 Color & Material Editor Dialog Boxes

More Features
Additional QuadroView features include:

� �Light Source Editor� on page 69

� �Cutting Plane Editor� on page 68

� Rendering Degradation (See �Preferences: Common Settings� on page 75.)

� Tools: grids, origins, . . (See �Preferences: AutoCAD Tools� on page 78.)

� Global Environment Mapping. (See �Render Toolbar� on page 54.)

� Named Views, Standard View, view handling, . . .(See �Views Toolbar� on 
page 58.)

� Scripting languages (See �QuadroView Commands in AutoCAD� on 
page 84.)
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C H A P T E R

3
SYSTEM REQUIREMENTS AND SUPPORT

This chapter contains the following major topics:

� �Release History� on page 29

� �Supported Languages� on page 30

� �System Requirements� on page 30

� �Supported Devices� on page 33

Release History
Table 3.1 contains a summary of NVIDIA QuadroView releases and the 
versions associated with them. Some versions listed may not have been released 
outside of NVIDIA.

Table 3.1 NVIDIA QuadroView Release History

Release Version Comments
Release 2.04 2.04.00 � 2.04.15 Releases ongoing 
Release 2.03 2.03.00 � 2.03.02  
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Supported Languages

User Interface
The NVIDIA QuadroView user interface support the following languages:

Online Help
The NVIDIA QuadroView online Help supports the following languages: 

System Requirements
Before you install and use NVIDIA QuadroView, make sure you have the 
prerequisites as explained in these sections:

� �Operating System� on page 31

� �Disk Space� on page 31

� �Hardware: Supported NVIDIA Products� on page 31

� �Stereo Requirements� on page 32

� �NVIDIA Driver Software� on page 32

� �Software Components� on page 32

� �AutoCAD Applications� on page 32

Chinese (traditional) German Norwegian
Chinese (simplified) Hungarian Polish
Czech Italian Russian
English Japanese Spanish
French Korean

Arabic Finnish Norwegian
Chinese (simplified) French Portuguese (Brazil)
Chinese (traditional) German Russian
Danish Italian Spanish
Dutch Japanese Swedish
English Korean Thai
N V I D I A  C o r p o r a t i o n  C O N F I D E N T I A L  30



N V I D I A  Q u a d r o V i e w  U s e r � s  G u i d e

BKNVRelQV_oem.book  Page 31  Friday, April 19, 2002  2:43 AM
Operating System
QuadroView is designed for the Microsoft operating systems listed in Table 3.2.

Disk Space
This release of NVIDIA QuadroView (English version) requires 40 MB of disk 
space.

Hardware: Supported NVIDIA Products
You need a workstation graphics card based on one of the NVIDIA products or 
an equivalent ELSA graphics card as listed in Table 3.3.

Note: NVIDIA QuadroView 2.03.00 and later versions will not run with the 
ELSA Synergy II graphics card. Older versions (earlier than 2.03.00) of 
NVIDIA QuadroView can run with ELSA Synergy II and ELSA driver 
software.

Table 3.2 Operating System Requirements
Operating System Minimum Requirements
Windows XP Home and Professional Editions
Windows 2000  
Windows NT 4.0 Service Pack 4 

Table 3.3 Supported NVIDIA Products

NVIDIA Workstation Product
Equivalent ELSA Graphics Card 
(distributed by ELSA)

Quadro� 4 500 GoGL
Quadro4 900 XGL 
Quadro4 750 XGL 
Quadro4 700 XGL 
Quadro4 550 XGL 
Quadro� DCC ELSA GLoria DCC
Quadro� 2 Pro ELSA GLoria III
Quadro2 MXR ELSA Synergy III
Quadro2 Go 

Quadro2 EX ELSA Synergy 2000
Quadro� ELSA GLoria II 
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Trial Period
As a first-time user of QuadroView, you have a 30-day demo/trial period where 
you may use a graphics card based on a non-NVIDIA graphics processor. 

Stereo Requirements
� If you have Quadbuffered OpenGL Stereo mode enabled in QuadroView, 

then you need stereo shutter glasses such as the ELSA 3D Revelator� or 
compatible glasses, such as those in the StereoGraphics product line.

� If you have Interlaced Stereo mode enabled in QuadroView, you need a 
stereo monitor such as the ELSA Ecomo 4D. (Interlaced stereo can be 
vertical or horizontal interlaced.)

� If you have Anaglyph Stereo mode enabled in QuadroView, you need special 
colored filter glasses. (Anaglyph stereo can be red/cyan, blue/yellow, green/
magenta.)

NVIDIA Driver Software
You need one of the following NVIDIA Drivers:

� NVIDIA Windows NT 4.0 Display Driver or
� NVIDIA Windows XP/2000 Display Driver 

Software Components
The NVIDIA QuadroView Setup directory contains the following files:

� Readme.txt file 

� Setup.exe installation program for Windows

� Other files required by the Setup program

Note: The NVIDIA QuadroView online HTML Help file (QuadroView*.chm) 
is installed in the NVIDIA QuadroView directory during installation.

AutoCAD Applications
AutoCAD must be installed on your system before you install NVIDIA 
QuadroView. 

NVIDIA QuadroView will work with any one of the following applications:

� AutoCAD 2002 
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� AutoCAD 2000i

� AutoCAD 2000

� AutoCAD Architectural Desktop Version 2

� AutoCAD Architectural Desktop Version 2i

� Mechanical Desktop 6

� Mechanical Desktop 5

� Mechanical Desktop 4

Note: You need to install AutoCAD before installing Architectural Desktop.

Supported Devices

3D Input Devices: Magellan/SpaceMouse / CyberPuck / 
SpaceController
NVIDIA QuadroView is pre-configured to work with Logitech, LogiCad 
Magellan 3D /Space Mouse and CyberPuck, and Spacetec SpaceController. 
These 3D input devices work in QuadroView Examiner Viewer mode; you can 
rotate and move the scene in real-time.

You can work with AutoCAD and QuadroView without toggling the focus 
between them. For example, you can use the 3D Mouse in QuadroView and the 
2D Mouse in AutoCAD, as you normally do. Use the Mouse cap as if it were the 
whole scene and rotate or translate the cap as follows: 

� Push or pull the cap in all directions to translate the scene. 

� Rotate the cap in all directions to rotate the scene. 

For better handling, you can regulate the speed of translation and rotation. For 
example, you can concentrate on specific movements by turning translation or 
rotation On/Off. If �dominant input� is turned on, the movement with the 
greatest magnitude is executed while the other movement is ignored.

Note: The LogiCad Magellan 3D/Space Mouse keys have the following 
functions:
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Note: The following functions apply while holding down the * key (Magellan 
only).

Note: For further details, carefully read the documentation of your 3D input 
device.

Note: You can use the 3D Input toolbar to adjust the sensitivity of rotation and 
translation for any supported 3D input device. The following versions of 
devices are supported: 

� Labtec driver (Version 8.1)

� LogiCad 3D driver (Version 4.5) 

Key Description

-1- Reduces sensitivity of translation.

-2- Enhances sensitivity of translation.

-3- Switches focus for QuadroView.

-4- Zooms All.

-5- Reduces sensitivity of rotation.

-6- Enhances sensitivity of rotation.

-7- Shows or Hides rotation point.

-8- Sends actual camera data to AutoCAD. (This button has no function while rendering 
in the AutoCAD viewport.)

Key Description

-1- Sets translation On or Off.

-2- Sets rotation On or Off.

-3- Sets dominant input On or Off.

-4- (Zeroing) Press this key if the image is drifting without moving the cap.

-7- (Null radius) Use this key to avoid movements caused by vibrations.

-8- Resets to the driver default, e.g., Null radius.
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Shutter Glasses
QuadroView supports Stereo viewing. To use this feature, you need shutter 
glasses connected to your NVIDIA GPU-based graphics card. 

Note: For further details, see the documentation of your shutter glasses.

Note: Also, refer to the OpenGL the NVIDIA Quadro Workstation User�s 
Guide
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C H A P T E R

4
INSTALLATION AND UNINSTALLATION

This chapter contains the following sections:

� �Before You Install QuadroView� on page 36

� �Installing QuadroView� on page 36

� �Starting QuadroView� on page 37

� �Uninstalling QuadroView� on page 39

Before You Install QuadroView
Before you install QuadroView, note the following:

� If you received the QuadroView installation package in compressed format, 
be sure to expand it retaining the subdirectory structure. Use the option �-d� 
for Pkunzip or, if you use another packer, use an equivalent option.

� Make sure that AutoCAD is installed but not running. 

Installing QuadroView
You can install NVIDIA QuadroView using either Standard mode or the Silent 
mode, as explained in the sections that follow.

Standard Mode
From the installation directory, click the Setup program and follow the prompts 
from the InstallShield program. 
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Silent Mode 
To run the Setup program without any dialog boxes and user input, you must 
create a response file. The response file will hold your responses to the dialog 
boxes that appear in a dialog driven installation. 

1 To build the response file, start the Setup program with the -r option, as 
shown:

setup.exe -r 

This command starts a dialog box driven Setup and creates the Setup.iss 
file in your Windows directory. Setup.iss stores the information you enter 
when you run Setup. 

No messages are displayed during a Silent Setup. Instead a log file named 
Setup.log captures installation information including whether the 
installation was successful or not. You can review the log file to determine 
the results of the installation. 

2 To start the Silent Setup, enter the following command: 
setup.exe -s -f1<path of setup.iss> -f2<path of setup.log> 

-s indicates that this is a Silent Setup.

-fl tells Setup where to find the response file.

-f2 tells the Setup where to write the log file. Without this option, the log file 
is created in the current directory. Since it is impossible to create a log file on 
a CD-ROM, specify another path where this file has to be created.

Example: The following is a sample command line for Silent Setup: 
setup.exe -s -f1c:\setup.iss -f2c:\setup.log 

If the installation program stops processing and generates an error message, 
try to run it with Administrator access rights. 

Starting QuadroView 

Starting QuadroView in Stand-alone Mode
To start QuadroView in stand-alone mode, from your Windows desktop, click 
Start > Programs > NVIDIA Corporation > QuadroView 2.04 > 
QuadroView.
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Loading QuadroView in AutoCAD
The loading mechanism for QuadroView in AutoCAD is called Demand 
Loading. The Demand Load Configuration dialog box appears for configuration 
during initial installation of QuadroView. 

1 To access the Demand Load Configuration dialog box at any time after first 
installation, from your Windows desktop, click:
Start > Programs > NVIDIA Corporation > QuadroView 2.04.0x > 
Demand Load Configuration

Figure 4.1 Demand Load Configuration

When you run Demand Load Confutation, the Demand Load Configuration 
box appears and displays a list of all installed versions of AutoCAD (or other 
AutoCAD-dependent application such as Mechanical Desktop) for which 
QuadroView is registered. Using the Demand Load Configuration dialog 
box, you can modify the startup functionality of QuadroView for one or more 
installed versions of AutoCAD (or other AutoCAD-dependent application 
such as Mechanical Desktop) for which QuadroView is registered. 

Note: AutoCAD & AutoCAD-based applications installed after QuadroView 
installation do not appear in the list. 

2 Automatic Loading: A check box appears in front of each line that contains 
the name of the AutoCAD application for which QuadroView is registered. If 
the check box is checked, QuadroView starts automatically when you start 
AutoCAD for each checked application. (To check an application that is not 
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checked, click the check box.) If the checkbox is unchecked, you have to use 
the NVSTART command to start QuadroView. 

3 Demand Loading: If you don�t want QuadroView to be loaded when 
AutoCAD starts, uncheck that application. You then have to start 
QuadroView using one of these methods:

� Enter the command NVSTART from the command line or
� Click the  icon on the NVIDIA QuadroView toolbar inside AutoCAD 

Note: Older releases of QuadroView provided a different method of 
automatic loading, which you can still use. If a batch file called 
Acad.rx exists in an AutoCAD working directory, the file attempts to 
load the .arx applications specified there. For QuadroView, a 
command line in the Acad.rx batch file may look like this: C:\…\
NVIDIA\QV_c.arx. If needed, you can specify the path where you 
installed QuadroView followed by the file name QV_c.arx.

4 After you�ve entered the setting you want, click OK to accept the changes.

If you do not want to make any changes or want to cancel the changes you�ve 
made, click Cancel. 

5 If, for any reason, AutoCAD does not start after QuadroView installation, re-
install QuadroView.

Uninstalling QuadroView
To uninstall NVIDIA QuadroView, follow these steps:

1 From the Windows desktop, click Start > Settings > Control Panel > 
Add/Remove Programs.

2 Click the Add/Remove Programs icon.

3 Click QuadroView from the list.

4 Click the Change/Remove button.

Follow the instructions from the InstallShield program to complete 
uninstallation. 
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C H A P T E R

5
QUADROVIEW MENUS

This chapter contains the following major topics:

� �NVIDIA QuadroView Menus� on page 40

� �File Menu� on page 41

� �Camera Menu� on page 43

� �Edit Menu� on page 44

� �View Menu� on page 45

� �Window Menu� on page 46

� �Help Menu� on page 46

NVIDIA QuadroView Menus

Main Menus

QuadroView contains the following main menus:

Context-Sensitive Popup Menus
When viewing an image inside the QuadroView window, in most cases, you can 
press the right mouse button to access a context sensitive pop-up menu. In most 

File Edit View  Camera Window Help
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cases, you can press the right mouse button to display a context sensitive pop-up 
menu. The context menu groups useful tasks available in the current context.

In most cases, you can press the right mouse button to display a context- 
sensitive pop-up menu. The context menu groups useful tasks available in the 
current context.

File Menu
The File menu contains the options described below. The options that show an 
icon are also available from the Standard toolbar. 

Table 5.1 File Menu Options

 Option Description
 File > Open Opens an existing file. The following file formats can be read:

Open Inventor (.IV files)
VRML version 1.0 (.WRL files)
VRML version 2.0 (.WRL files) 

 File > Open Link Opens or close a link to an AutoCAD drawing.
This command lists all documents opened in AutoCAD in a dialog box. Documents 
that currently have a link to a document in NVIDIA QuadroView are checked. To 
establish a link to an AutoCAD document, click the document to place a check next 
to it. If you uncheck a document, it will be closed in QuadroView.

Example:
1 Start AutoCAD with QuadroView 
2 Load several drawings.
3 Click File > Open Link from QuadroView. A list box displays the names of the 

opened drawings 
4 Select or unselect the drawing in this list. Notice that the unlinked drawings close 

immediately.
5 Select the unselected drawing. QuadroView will immediately load the drawing 

from AutoCAD immediately 

KeyKeyKeyKeyKey CTRL + O

KeyKeyKeyKeyKey CTRL + L
41 C O N F I D E N T I A L N V I D I A  C o r p o r a t i o n



N V I D I A  Q u a d r o V i e w  U s e r � s  G u i d e  

BKNVRelQV_oem.book  Page 42  Friday, April 19, 2002  2:43 AM
 Option Description
 File > Link Establishes a file link to the currently opened document file. The QuadroView viewer 

will reload the document whenever the file is changed by another program, so that 
you can see the changes. You can use this option to link the QuadroView viewer to 
another CAD application that can save files in .iv or .wrl formats.  
Note To use this option, the file must be located on the same computer on which the 
QuadroView viewer is started. The option does not work over the network.

Example:
1 Open an application such as ProEngineer and create a drawing. 
2 Select Export as VRML and save the drawing to disk; you can use demo.wrl. as 

the file name.
3 Start QuadroView and load the drawing (demo.wrl) 
4 Click File > Link in QuadroView. 
5 Edit the drawing in ProE and again export it to demo.wrl. QuadroView will 

detect that the file has changed and will automatically reload demo.wrl 
File > Close Closes the active document.

 File > Save Saves the model under the current name as an Open Inventor file.
This command saves the current model under the current name in an Open Inventor 
file. If the model has not yet been named, the dialog box for Save As automatically 
appears so that you can name the file.
You can also use this command to save the model under another name or in another 
directory or create a file with another format.

File > Save As. . . . Saves the model under a different name and in a specific graphics format.
This command opens a dialog box in which you can define the disk drive, directory, 
file name, and file format of the current file. The following formats are available:
� Open Inventor (.iv files)
� Bitmap (.bmp files)
� Postscript (.eps files)
� SGI-RGB (.rgb files)
� TIFF (.tif files)
� JPEG (.jpg files)
� VRML, version 2.0 (.wrl files) 

If you have already saved the file and you want to save changes under the same 
name, use File > Save.

 File > Print Sends the opened file to the printer.

File > Print 
Preview

Displays a Print Preview of the file.

 Print Setup Selects and set up an installed printer.

Table 5.1 File Menu Options (continued)

KeyKeyKeyKeyKey ALT + CTRL + F 

KeyKeyKeyKeyKey CTRL + S

KeyKeyKeyKeyKey CTRL + P
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Camera Menu
The Camera menu contains the options described below. The options that show 
an icon are also available from the Viewer toolbar. 

 Option Description
1 . . .[file name]
2. . . [file name]
3 . . . [file name]
4 . . .[file name] 

Quickly accesses the most recently used files.

Exit Exits QuadroView.

Table 5.1 File Menu Options (continued)

Table 5.2 Camera Menu Options
 Option Description

 Update AutoCAD 
View

Updates AutoCAD view. Sends the current camera settings to AutoCAD.

 Save Home Position Saves current camera settings as Home position. Saves the current view. You can 
save only one view at a time. To retrieve the saved view, use the Restore Home 
Position option.

 Restore Home 
Position

Sets camera to Home position. Any view can be retrieved if it has previously been 
saved using the Save Home Position option.

Pre-defined Views Selects from the AutoCAD pre-defined views.
Animation Contains the same options as the �Animation Toolbar� on page 50.

 View All Zooms out to see the entire scene. The model may lie (partially or entirely) 
outside of your camera view, or you may wish to change quickly from a 
close-up view to the total view. Click this button to bring the object back to 
the center of the view.

 Perspective Camera Toggles between the Perspective and Orthogonal display of the scene. 

 Seek To Point Seeks object to define rotation point. You can re-orient any desired surface 
of the object to be parallel to the viewing plane. The selected point becomes 
the model�s new rotation point.

 Up Vector Sets the Up Vector of the current scene. Defines the �floor� when using the 
Fly or Walk Viewer. 

KeyKeyKeyKeyKey V

KeyKeyKeyKeyKey T

KeyKeyKeyKeyKey S

KeyKeyKeyKeyKey CTRL + U
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Edit Menu
The Edit menu options are described below. The options that show an icon are 
also available from the Editors toolbar. 

 Option Description
Stereo Controls stereo handling; contains the same options as the �Stereo Toolbar� 

on page 55.
3D Input Devices Adjusts the sensitivity of the 3D input device you may be using; contains the 

same options as the �3D Input Toolbar� on page 50.

Table 5.2 Camera Menu Options (continued)

Table 5.3 Edit Menu Options
 Option Description

 Edit Mode Toggles between Observer and Selection modes. 
Selection mode: Use the arrow pointer to mark an object, move �Light Sources� on 
page 70, or change the direction of Light Sources. 
Observer mode: Use the hand pointer to move the object around.

 Cutting Plane Shows the �Cutting Plane Editor� on page 68. This editor allows you to cut away 
parts of your drawing so you can look into the inner space of your objects.

 Background Color Opens the �Background Color Editor� on page 62.
 Material Opens the �Material Editor� on page 65.

LIGHTS (submenu)
 Create Light Source Opens the �Light Source Editor� on page 69 where you can create and save a new 

light source.
 Show/Hide Light 

Sources
Click the  part of this icon to toggle between showing and hiding light source 
icons on the scene. 
To edit a specific light source, either double click its icon from the scene, or select it 
from the drop-down list by clicking the down arrow icon.

 Adjust Icon Size Adjusts the icon size of the light source with respect to the current scene size.
 All Lights On Turns on all light sources.
 All Lights Off Turns off all light sources.
 Headlight Toggles on/off the Headlight. The Headlight is the default light source in the viewer.
 Headlight Editor Opens the �Headlight Editor� on page 73 dialog box.

KeyKeyKeyKey The ESC key can a
be used to toggle

.

between Selection mode and
Observer mode.

Key

KeyKeyKeyKeyTip In Selection mode, you can temporarily switch back to Observer Tip
mode by holding down the ALT key while using the mouse.

KeyKeyKeyKeyTip When you enable (turn on) the Cutting Plane Manipulator, additional
options are added to the pop-up menu that you can access by clicking
.the right mouse button.
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View Menu
The View menu contains the options described below. The options that show an 
icon are also available from the Viewer toolbar. 

Table 5.4 View Menu Options 
 Option Description

Toolbars To display the QuadroView Toolbars submenu, you can follow any one of these 
options:
� Click View > Toolbars from the QuadroView main menu and then click to toggle 

any one of the toolbars you want to display or hide.
� Right click while the cursor is in the toolbars docking area or in the viewer area.
See �QuadroView Toolbars� on page 48 for details on the various toolbars.

 Examiner Viewer Switches to �Examiner Viewer� on page 14 mode.

 Walk Viewer Switches to �Walk Viewer� on page 17 mode.

 Fly Viewer Switches to �Fly Viewer� on page 16 mode.

Render Still Sets the Render mode while the model is not animated. Choose from Wireframe, 
Hiddenline, Flat Shaded, and Gouraud Shaded.
See �Render Toolbar� on page 54 for 

 
Render Interactive 
Mode

Sets the Render mode while the model is animated. You can choose from the 
following modes:
� Wireframe
� Hiddenline
� Flat Shaded 
� Gouraud Shaded
The same options are also available from the �Render Toolbar� on page 54.

 Preferences Opens the Preferences dialog box. See �QuadroView Preferences Settings� on 
page 74.

KeyKeyKeyKeyTip  Tip You can also access this option from the Render toolbar.
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Window Menu
The Windows menu contains the options described below.

Table 5.5 Window Menu Options

Help Menu
The Help menu options are described below.

Table 5.6 Help Menu Options

 Option Description

 Maximize Render Area Toggles between maximizing/restoring the render area and removing/adds 
items such as toolbars, menus, and titles.
To access this option, you can use the shortcut key (F11) or the context menus 
(right click) to control viewing parameters while the render area is maximized.

 Cascade Cascades open windows.

 Tile Tiles open windows.

Arrange Icons Arranges minimized windows.

List of Open Windows Switches to the selected window.

KeyKeyKeyKeyKey F11

 Option Description

 Help Topics Opens the QuadroView online Help system. You can press F1 at any time 
within QuadroView to open Help.

www.NVIDIA.com Goes to the web page of NVIDIA Corporation.

 About QuadroView Shows the �About NVIDIA QuadroView� box, which contains information on 
copyright and the graphics card that is installed.

KeyKeyKeyKeyKey F1
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C H A P T E R

6
QUADROVIEW TOOLBARS

This chapter contains the following major topics:

� �NVIDIA QuadroView Toolbar in AutoCAD� on page 48

� �Standard Toolbar� on page 49

� �3D Input Toolbar� on page 50

� �Animation Toolbar� on page 50

� �Editors Toolbar� on page 53

� �Render Toolbar� on page 54

� �Stereo Toolbar� on page 55

� �Viewer Toolbar� on page 57

� �Views Toolbar� on page 58

NVIDIA QuadroView Toolbar in AutoCAD
The NVIDIA QuadroView toolbars are loaded when you run AutoCAD for the 
first time after setting up QuadroView to run within AutoCAD. For details, 
see�QuadroView Toolbar Options in AutoCAD� on page 86.
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Standard Toolbar
To access the Standard Toolbar, right click from inside QuadroView or use the 
menu sequence shown below.

.
Table 6.1 Standard Toolbar Options

Option Description

 Open Opens an existing file.

 Save Saves the model under the current name as an Open Inventor 
file.

 Open Link Opens a link to an AutoCAD Drawing.

 File Link Establishes a file link to the currently opened document file. 
The Viewer reloads the document whenever the file is changed 
by another application. This option can be used to link the 
Viewer to another CAD application that can save a file in IV or 
VRML format.
To use this option, the file must be located on the same 
machine on which the Viewer is started. Note that the option 
does not work over the network.

 Print Sends the current file to the printer.

 Print Preview Displays a Print Preview of the file.

 Preferences Opens the Preferences dialog box.

 About Shows the �About NVIDIA QuadroView� information. View 
information about QuadroView and the graphics card that is 
installed.

 Context Help To receive context-sensitive Help, click the icon, move the 
mouse to drag the ? icon to the area of the QuadroView 
window on which you need Help, and click again to display 
the Help.

Menu View > Toolbars > Standard (toggles toolbar on and off)

Toolbar
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3D Input Toolbar
To access the 3D Input Toolbar, right click from inside QuadroView or use the 
menu sequence shown below.

NVIDIA QuadroView is pre-configured to work with the following 3D input 
devices: Logitech, LogiCad Magellan 3D/Space Mouse and CyberPuck, and 
Labtec SpaceController.

Animation Toolbar
Note: The Animation Toolbar options are only available when you are using the 

�Examiner Viewer� on page 14 mode in a scene that contains animation 
data. The options are not available (grayed out) in �Fly Viewer� on 
page 16 and �Walk Viewer� on page 17 modes and if the scene does not 
contain animation data.

To access the Animation Toolbar, right click from inside QuadroView or use 
the menu sequence shown below.

Table 6.2 3D Input Toolbar Options

Option Description
 Enhance Translation Sensitivity If rotation is too slow, you can enhance the rotation 

sensitivity. 
 Reduce Translation Sensitivity If translation is too fast, you can reduce the translation 

sensitivity. 

 Enhance Rotation Sensitivity If rotation is too slow, you can enhance the rotation 
sensitivity. 

 Reduce Rotation Sensitivity If rotation is too fast, you can reduce the rotation 
sensitivity.

Menu View > Toolbars > 3D Input (toggles toolbar on and off)

Toolbar

Menu View > Toolbars > Animation (toggles toolbar on and off)

Toolbar
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Saving an AVI File
To create an .AVI file, click the Create AVI  icon from the Animation toolbar 

1 Enter a file name and click Save to display the AVI Settings dialog box 
(Figure 6.1).

Figure 6.1 AVI Settings

Table 6.3 Animation Toolbar Options
Option Description

 Play Forward Plays animation forward.

 Go to End Goes to the end (last frame) of the animation.

 Play Backward Plays animation backward (reverse direction).

 Go to Start Goes to the start (first frame) of the animation.
 Stop Stops the animation.
Select Camera Path The Camera Path is the spline curve on which the camera 

moves while the animation is playing.
 Select LookAt Path The LookAt Path defines the target curve of the camera.
 Show/Hide Camera Path Toggles the visibility of the Camera Path in the scene.
 Show/Hide LookAt Path Toggles the visibility of the LookAt Path in the scene.
 Animation Editor Opens the Animation Editor dialog box from which you 

can control the animation sequence.
 Send Animation Data to 

AutoCAD
Sends animation data to AutoCAD and updates the data 
there.

 Create AVI Saves an AVI file of the current animation to disk. When 
you click this icon, the Save As dialog box appears. 
Note: See Saving an AVI File in the next section for 

further details.
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2 Click the down arrow on the Output Size list box to display choices.

3 You can select one of the pre-defined numeric sizes or select one of the 
following options:

� Current viewport size, which uses the size of the render area window  

� Custom, where you specify the Width and Height from the drop down lists 
or select an Output Size from the list of values.  

The Image Aspect Ratio value is automatically calculated as Width divided 
by Height.

4 Select an FPS (frames per second) from the list of values or click Default.

5 (Optional) Check Antialiasing. Using antialiasing makes lines and edges 
smoother but increases the time required to create the AVI file.

6 Click OK when you are done to open the Video Compression dialog box 
(Figure 6.2). The Video Compression dialog box lets you select the installed 
third-party compressors of your system.

Figure 6.2 Video Compression

7 Select the desired compression codes from the Compressor list box or select 
Full Frames (Uncompressed) if you do not want compression. (If you 
discover problems using a special compression code, contact the company 
delivering the compression code.)

8 (Optional) Use the Compression Quality slider to adjust the value.

9 (Optional) Click the Configure button to configure the compressor, then click 
OK when you're done.

10Click OK again to close the Video Compression dialog box.
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Editors Toolbar
To access the Editors Toolbar, right click from inside QuadroView or use the 
menu sequence shown below.

.
Table 6.4 Editors Toolbar Options

Option Description
 Background Color 

Editor
Click to open the Background Color Editor.

 Material Editor Click to open the Material Editor.

 Cutting Plane Click to show the Cutting Plane Manipulator, which lets you to 
cut away parts of your drawing so you can look into the inner 
space of your objects. 
Enabling the Cutting Plane Manipulator adds additional choices 
to the pop-up menu, which you can access by clicking the right 
mouse button.

 Create Light Source Click to open the Light Source Editor dialog box where you can 
create and save a new light source.

 Show/Hide Light 
Source Icons

Click to toggle between showing and hiding light source icons. 
To edit a specific light source, either double click its icon or 
select it from the drop-down list.

 
Change Icon Size

Click the icon wheel and move the mouse right or left to change 
the icon size of the light source.

Adjust Icon Size

Click to adjust the icon size of the light source in relation to the 
size of the current scene.

 All Lights On Click to turn on all light sources.

 All Lights Off Click to turn off all light sources.

 Headlight Click to toggle on/off the Headlight. The Headlight is the default 
light source in the viewer.

 Headlight Editor Click to open the Headlight Editor.

 Background Color Click to open the Background Color Editor.

Menu View > Toolbars > Editor (toggles toolbar on and off)

Toolbar
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Render Toolbar
To access the Render Toolbar, right click from inside QuadroView or use the 
menu sequence shown below.

.
Table 6.5  Render Toolbar Options

Option Description

 Examiner Viewer Switches to �Examiner Viewer� on page 14 mode.

 Walk Viewer Switches to �Walk Viewer� on page 17 mode.

 Fly Viewer Switches to �Fly Viewer� on page 16 mode.

 Global Environment 
Mapping

Renders model to chrome-like appearance with the 
environment mirroring on the surface.

 
Render Interactive Mode

Sets the Render mode while the model is animated. You can 
choose from Wireframe, Hiddenline, Flat Shaded and Gouraud 
Shaded.

Render Still Mode
Sets the Render mode while the model is not animated. You 
can choose from Wireframe, Hiddenline, Flat Shaded and 
Gouraud Shaded.

Menu View > Toolbars > Render (toggles toolbar on and off)

Toolbar
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Stereo Toolbar
To access the Stereo Toolbar, right click from inside QuadroView or use the 
menu sequence shown below.

Note: QuadroView supports a variety of stereo formats and stereo hardware. 
You can choose different Stereo Modes as described in the �Preferences: 
I/O Settings� on page 76.

You can configure stereo viewing and handling by using either the Stereo 
Toolbar options described below in Table 6.6 or by using the same options from 
the Camera > Stereo submenu. 
Table 6.6 Stereo Toolbar Options 

Option Description
 Stereo Toggles stereo mode between monoscopic (off) and 

stereoscopic (on) viewing.

Stereo Offset keys measure the distance between the two rendered pictures. Use stereo offset 
carefully; too much offset may result in ghosting effects.

 Stereo Offset Default Resets stereo offset to the default value.
Measures the distance between the two rendered pictures. Use 
stereo offset carefully; too much offset may result in ghosting 
effects

 Stereo Offset + Increases the amount of stereo offset.

 Stereo Offset -- Decreases the amount of stereo offset.

The Parallax affects the virtual position of the objects. By decreasing the parallax balance value, 
objects appear between you and the screen plane. By increasing this value, the objects appear 
behind the display plane.

Menu View > Toolbars > Stereo (toggles toolbar on and off)

Toolbar

Key F12

Key F10

Key +ALT

Key +ALT
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Option Description
 Parallax Default Sets the parallax balance to the default value.

 Parallax - Decreases the parallax balance value.
.z

 Parallax + Increases the parallax balance value.

Reverses Views. Exchanges the left and the right view

 Maximize Render Area Toggles between maximizing/restoring the render area and 
removing/adds items such as toolbars, menus, and titles. 
Note: Use shortcuts to control viewing parameters while the 

render area is maximized.

Table 6.6 Stereo Toolbar Options  (continued)

Key F9

Key +ALT

Key +ALT

Reverse Views

Key Shift + F12

Key F11
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Viewer Toolbar
To access the Viewer Toolbar, right click from inside QuadroView or use the 
menu sequence shown below.

Table 6.7 Viewer Toolbar Options 

Option Description
 Edit Mode Click the  button to toggle between Observer and Selection 

modes. You can also use the ESC key to perform the same 
function. 
Selection mode: Use the arrow pointer to mark an object, 
move �Light Sources� on page 70, or change the direction of 
Light Sources. 
Observer mode: Use the hand pointer to move the object 
around

 Save Home Position Saves current camera settings as Home position. Click this 
button to save the current view. You can only save one view at 
a time. To retrieve the saved view, click the Restore Home 
Position button.

 Restore Home Position Saves camera to Home position. Click this button to retrieve 
the last view that was stored using the Save Home Position 
button.

 View All Zooms out to see the entire scene. The model may lie (partially 
or entirely) outside your camera view, or you may want to 
quickly change from a close-up view to the total view. Click 
this button to bring the object back to the center of the view. 

 Seek to Point Seeks object to define rotation point. You can re-orient any 
desired surface of the object to be parallel to the viewing plane. 
The selected point becomes the model�s new rotation point. 

Up Vector Sets the Up Vector of the current scene. Use this tool to define 
the �floor� when using the Fly or Walk Viewer. 

 Perspective Camera Toggles between the Perspective and Orthogonal display of 
the scene.

Menu View > Toolbars > Viewer (toggles toolbar on and off)

Toolbar

Key ESC
[ALT + mouse]

KeyKeyKeyKeyTipTip In Selection mode, you can temporarily switch back

 
to Observer mode by holding down the Alt key
while using the mouse.

Key V

Key S

Key U

Key T
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Views Toolbar
To access the Views Toolbar, right click from inside QuadroView or use the 
menu sequence shown below.

Table 6.8  Views Toolbar Options

Option Description
 Named Views This option defines (sets) Named Views. You can define a new 

Named View (to be sent to AutoCAD) or you can choose a pre-
defined view from the drop down list of Named Views.

 Predefined Views Select from a list of pre-defined views:
Standard Views: Top, Bottom, Left, Right, Front, and Back
Isometric Views: Southwest, Southeast, Northeast, and 
Northwest

 Update AutoCAD View Sends the current camera settings to AutoCAD.

Menu View > Toolbars > Views (toggles toolbar on and off)

Toolbar
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C H A P T E R

7
QUADROVIEW EDITORS

This chapter contains the following major topics:

� �Animation Editor� on page 60

� �Background Color Editor� on page 62

� �Material Editor� on page 65

� �Cutting Plane Editor� on page 68

� �Light Source Editor� on page 69

� �Headlight Editor� on page 73

Animation Editor
For an overview of animation, see �Animation� on page 24.

You can fine-tune an animation (e.g., an open scene with animation data) with 
the Animation Editor, which allows you to control the animation sequence. 
Using this editor, you can define keys on the animation paths, time and twist 
values, etc. 

Menu Camera > Animation > Animation Editor

Button on the Animation toolbar
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Figure 7.1 Animation Editor 

Table 7.1 Animation Editor Options 

Option Description
Paths The Paths window displays the Camera Path, the LookAt Path, and the different 

key markers on the paths.
Camera Click the check box to toggle between showing and hiding  the Camera Path in the 

path window.
LookAt Click the check box to toggle between showing and hiding the LookAt  Path in the 

path window.
World Up Vector Click X-, Y-, or Z- Axis to define the Up Vector of the world. (The vector points 

to the �ceiling� or �head� perspective.)
Camera Path slider Click the slider to move the currently selected key marker on the Camera Path to 

bring it into the appropriate position.
LookAt Path slider Click the slider to move the currently selected key marker on the LookAt Path to 

bring it into the appropriate position.
Path Delete buttons The path delete buttons are represented by icons (buttons) and appear to the right 

of the sliders. Click the appropriate button to delete either the Camera Path or the 
LookAt Path.

Key list table This table contains animation data; i.e.,  key names for Camera Path and 
LookAt Path, Time, and Twist, as shown in the Animation Editor example 
above.
In the example,  A_B and A_B are corresponding points; one on the 
Camera Path and one on the LookAt Path. The animation must reach this key 
after 15 seconds (Time = 15). There is no rotation (Twist = 0) around the viewing 
axis.
The Twist value can be greater/smaller than +/-360°, which means more than one 
complete rotation.
To edit any value in the table, double-click the item (Camera Path, LookAt Path, 
Time, or Twist) you want to edit.
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Background Color Editor

Use the Background Color Editor to easily change the background color of the 
scene. This section describes the Color Editor dialog boxes

Note: Depending on the type of Color Editor you are using, the dialog box 
shown for Background Color Editor may be labeled Directional 
Light Color Editor (included below), Light Source Color Editor, and 
so on.

Option Description
New Key A key defines the place on the Camera Path, the target on the LookAt Path, the 

Timestamp, and the Twist of the camera. When you click the New Key button, a 
new key is inserted in the middle of the interval before the selected key, unless you 
are selecting the first key in the list.

Delete Key Click to delete the selected key entry.
Automatic LookAt Path Click to check this box if you want to generate an animation sequence without 

defining a LookAt Path. In this case, the camera moves tangentially on the Camera 
Path.

Loop Check this box to automatically restart the animation when it reaches the end.
Real-time If you check this box, the Animation player attempts to implement the specified 

time constraint in the key list table. If you do not check Real-time, the specified 
time is not taken into consideration.

FPS (frames per second) Click the up or down arrow to set the number of frames per second (FPS) for 
framed-based support for animation.

Table 7.1 Animation Editor Options  (continued)

Menu Edit > Background Color

Button on the Editors toolbar 
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Background Color Editor

Figure 7.2 Background Color Editor 

Use the Background Color Editor to easily change the background color of the 
scene. The image on the left has the Sliders menu set to RGB HSV

You can drag the marker in the color wheel to select a color. You move the V 
(value) slider to control the intensity of the color. The Sliders menu offers 
different color models.

The color boxes display the currently selected color and the previous color. You 
can use the arrow buttons to switch back and forth between the colors. Use the 
right arrow to save a color from the left to the right box. Use the left arrow to 
retrieve a color from the right to the left box. Use the dual-arrow to switch 
colors between the two boxes.

By default, the scene is automatically updated as you modify the color. This can 
be altered through the Edit menu.

Menu Edit > Background Color

Button on the Editors toolbar
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Headlight (Directional Light) Color Editor

Figure 7.3 Directional Light Color

Note: See the explanation of the options in �Background Color Editor� on 
page 63.

Menu Edit > Lights > Headlight Editor > Edit > Color Editor

Button on the Editors toolbar
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Material Editor

The Material Editor lets you change the material of a selected object. The preview window shows 
a sphere with the actual Material settings.

Note: You cannot save changes made to Material in the original AutoCAD 
drawing. You can save the Material only in inventor (.iv) or VRML (.wrl) 
files.

Figure 7.4 Material Editor.

Edit Menu

Table 7.2  Material Editor: Edit Menu
Option Description
Material Palette Opens the Material Palette. (See �Material Palette Editor� on page 67)
Continuous Material changes immediately take effect on the selected object in the 

scene. This is interactive Material handling.
Manual Material changes only take effect after you click the Accept button.
Copy Copies the Material data to the clipboard.
Paste Pastes the Material data from the clipboard to the editor.

Menu Edit > Material

Button on the Editors toolbar
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Options Menu

Edit Color: Toggle Buttons
There are two columns of options on the left of the sliders.

Sliders

Table 7.3  Material Editor: Options Menu
Option Description
Always on Top The dialog box always stays on top of all other windows.

Table 7.4 Material Editor: Edit Color Toggle Buttons
Option Description
Left Column The left column of options is Single Selection edit. For a particular slider, 

if you select the option in the left column, the option in the right column 
becomes selected and all other selected options for the sliders are 
unselected. If you now change the color in the color editor dialog box that 
appears, you can only change the color of that particular slider.

Right Column The right column of options is Multiple Selection edit. You can click the 
right column option for more than one slider to simultaneously edit the 
colors for all the selected sliders in the color editor dialog box.

Table 7.5  Material Editor: Sliders
Option Description
Amb Changes intensity of Ambient component.
Diff Changes intensity of Diffuse component.
Spec Changes intensity of Specula component
Emis Changes intensity of Emissive component.
Shininess Changes roughness of Material.
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Material Palette Editor

This Material Palette dialog box displays various Materials in a preview 
window. You can click your favorite Material to assign to the selected object in 
the scene or load other pre-defined Material Palettes to select a Material that 
suits your needs.
Figure 7.5 .Material Palette Editor

Table 7.6  Material Palette Options
Option Description
Edit Menu
� Color Opens the Color Editor
� Material Opens the Material Editor
� Copy Copies Material data to the clipboard
Palette Menu
� Basic  Shows the standard Material Palette.

...  Selects your favorite Material Palette.
Options
�  Always on Top The dialog box always stays on top of all other windows.
�  Material Path Shows QuadroView the location of the color palettes.

Menu Edit > Material > Edit > Material Palette

Button Click on the Editors toolbar, then Edit (menu) > Material Palette.
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Cutting Plane Editor

The Cutting Plane editor lets you look into objects by clipping away 
unnecessary areas. You can move, size, and rotate the cutting plane by clipping 
the manipulator shown in Figure 7.6.
Figure 7.6 Cutting Plane Editor

Table 7.7  Cutting Plane Editor Settings
Setting Description
(1) Click here to pan the manipulator in the cutting plane.
(2) Click here to rotate the entire cutting plane.
(3) Click here to resize the manipulator.
(4) Click here to move the entire cutting plane along the axis.

Menu Edit > Cutting Plane

Button on the Editors toolbar
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Light Source Editor

The Light Source Editor dialog box lets you easily create, edit, and delete Light 
Sources from within NVIDIA QuadroView. 

When the Light Source Editor box is open, all the light sources in the scene are 
shown as manipulators and the name of every light source is connected directly 
to the manipulator so that you can easily distinguish among the light sources. 

The active (selected) light source name is highlighted in red. You can directly 
manipulate the light source data using either the mouse and the manipulators or 
the dialog box. QuadroView supports several types of Light Sources, as 
described in �Light Sources� on page 70.

Creating and Editing Light Sources
1 To create a new light source, 

� Click the Create Light Source icon in the Editors Toolbar or 

� Click the Edit menu, then click Lights > Create Light Source. 

The Light Source Editor dialog box opens. Table 7.8 explains how to use 
the options. 

Figure 7.7 Light Source Editor.

Menu Edit > Lights

Button on the Editors toolbar
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2 Once you have named and created a light source, you can click the Show/Edit 
Light Sources icon  to toggle between showing and hiding the light 
light source on the image in the viewer.

3 To edit the light source you created:

a Click the down arrow to select the light source you created 

b Click the light source name it to edit it in the Light Source Editor dialog 
box.

Light Sources

QuadroView supports the following types of light sources:
� �Point Light� on page 71

� �Spotlight� on page 71

Table 7.8  Light Source Editor Options
Option Description
Name Enter a new name or edit an existing name of the Light Source.
Change Icon Size Click the icon wheel and move the mouse right or left to change the icon 

size of the Light Source.

Adjust Icon Size
 ><

Click to adjust the icon size of the Light Source in relation to the size of 
the scene.

Location Shows the actual position of the light source.
Direction Shows the direction to which the light source points.
Spotlight Light source is a �Spotlight� on page 71.
Point Light Light Source is a �Point Light� on page 71.
Directional Light Light Source is a �Directional Light� on page 72.
Intensity Intensity is in the range between 0.0 - 1.0.
Drop-off Rate Drop-off Rate is in the range between 0.0 -- 1.0. This factor defines how 

quickly the light drops in intensity as it goes outside the specified cone of 
illumination.

Cut-off Angle Defines the cone that the light source illuminates.
Edit Color Opens the Color Editor that lets you change the color of the Light Source.
On Switches the selected Light Source on or off.
Accept Accepts the Light Source data and sends it to AutoCAD.
Cancel Cancels all changes or deletes newly created light sources, depending on 

the task (creating or editing) you performed previously.
Delete Deletes the selected Light Source.
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� �Directional Light� on page 72 

Point Light
The point light radiates light equally in all directions.

� To move the light source over a plane, select the sphere (1) of the 
manipulator

� To switch to another plane, select the sphere (1) and press the CTRL key 
together. 

� To move the light source along this axis, select the axis (2) on the sphere. 

� To switch to another axis on which to move the light source, select the 
axis (2) and press the CTRL key together 

Spotlight
The Spotlight works like the spotlight on your car. It creates a cone of light 
pointing in one special direction. The intensity drops down to the outer limits of 
the cone. You can change the drop-off rate and the cut of angle of the cone.

! To move the light source over a plane, select the sphere  (1) of the 
manipulator. 

! To switch to another plane, select the sphere (1) and press the CTRL key 
together. 
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� To move the light source along this axis, select the axis (2) on the sphere. 

� To switch to another axis along which to move the light source, select the 
axis (2) and press the CTRL key together. 

� To change the pointing direction of the light source, drag the arrow (3) to 
the specified direction. 

� To change the cut-off angle of the light source, select the cone (4) and 
change its radius. 

Directional Light
The Directional Light illuminates the scene uniformly in its pointing direction. 
Since the light beams are parallel, they simulate a light source that is infinitely 
far away and thus do not need a position. For easier handling, a position has 
been added to place the manipulator.

! To move the light source over a plane, select the sphere (1) of the manip-
ulator 

! To switch to another plane, select the sphere  (1) and press the CTRL key 
together 

! To move the light source along this axis, select the axis (2) on the 
sphere. 

! To switch to another axis on which to move the light source, select the 
axis (2) and press the CTRL key together. 

! To change the pointing direction of the light source, drag the arrow (3) 
to the specified direction. 
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Headlight Editor

Use the Headlight Editor to determine the direction from which the headlight 
should illuminate the scene and invoke the Color Editor in order to change the 
Headlight color.
Figure 7.8 .Headlight Editor

� Intensity Slider Controls the intensity of the light source.  

� Edit Menu
� Color Editor: Opens the Headlight (Directional Light) Color Editor.

� Copy/Paste: Saves a previous Headlight position and retrieve it later.

� Help: Starts online Help.

� Options Menu
� Always on Top always keeps the Editor in front of other windows. 

Menu Edit > Lights > Headlight Editor

Button on the Editors toolbar
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C H A P T E R

8
QUADROVIEW PREFERENCES SETTINGS

This chapter contains the following sections:

� �Preferences: Overview� on page 74

� �Preferences: Common Settings� on page 75

� �Preferences: I/O Settings� on page 76

� �Preferences: AutoCAD Tools� on page 78

� �Preferences: AutoCAD Link� on page 80

Preferences: Overview

The QuadroView Preferences configuration window lets you define 
fundamental parameters, such as the object types to be displayed and 
communication between AutoCAD and QuadroView.

The Preferences window contains the following tabs:

� �Preferences: Common Settings� on page 75

� �Preferences: I/O Settings� on page 76

� �Preferences: AutoCAD Tools� on page 78

� �Preferences: AutoCAD Link� on page 80

Menu View > Preferences

Button on the �Standard Toolbar� on page 7
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Preferences: Common Settings

Figure 8.1 Preferences: Common Settings

.
Table 8.1  Preferences: Common Settings

Option Description
Shading 
(Render 
Degradation)

QuadroView can automatically switch to a less calculation-intense render 
style as long as the model is moved. 
Interactive work with complex scenes can be processed faster by 
switching animated rendering back to the simpler Wireframe 
representation and using the Shaded representation only in the non-
animated state.

Transparency QuadroView lets you assign Transparency to objects using the �Material 
Editor� on page 65. You can select from different types of Transparency 
options.

Menu View > Preferences > Common Settings
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Preferences: I/O Settings

Figure 8.2 shows the I/O Settings dialog box.

3D Input Devices
NVIDIA QuadroView is pre-configured to work with the following 3D input 
devices when you are in QuadroView �Examiner Viewer� on page 14 mode.

� Logitech LogiCad Magellan 3D/Space Mouse, including CyberPuck

� Spacetec SpaceController

Using these devices, you can rotate and move the scene in real-time. You can 
adjust the sensitivity of the 3D input devices by using the �3D Input Toolbar� 
on page 50 which appears automatically when you select a 3D input device. 

Option Description
Backface Culling When this option is checked, backfaces of polygons are excluded when 

rendering the scene, which makes the process of rendering faster. You can 
also activate this option for transparent objects if you can see rendering 
artifacts; however, not checking this option yields better results for other 
types of objects.

Fast Animation Fast Animation is turned on by default and used to speed up the 
animation. Each Light Source slows down the rendering while rotating or 
moving the scene.
When Fast Animation is checked, you can turn off all lights and only use 
the Headlight while moving the scene

Complexity In order to control the quality of rendering, VRML (.WRL) files and Open 
Inventor (.IV) files may contain elements that react to the Complexity 
setting.
The higher the complexity, the lower the overall rendering performance.

Texture Quality To control the quality of rendering, VRML (.WRL) files and Open 
Inventor (.IV) files may contain textures that react to the Texture Quality 
setting. 
The higher the texture quality, the lower the overall rendering 
performance.

Default Restores all values to their standard settings.

Table 8.1  Preferences: Common Settings (continued)

Menu View > Preferences > I/O Settings
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Figure 8.2 Preferences > I/O Settings

Stereo Modes
QuadroView supports Stereo viewing of the rendered scene. You can choose 
from different formats. Click the down arrow in the Stereo Modes field to view 
and select a mode. 

Notes: 
� Some formats require the viewer to be restarted.

� Be sure to enable the stereo mode in your graphics card driver settings, if 
needed. 

Table 8.2 QuadroView Stereo Modes

Stereo Modes Description
Quadbufferred/Raw OpenGL Stereo Make sure your graphics card supports this stereo 

format. You will also need shutter glasses, such as a 
3D Revelator.

Blue / Yellow Stereo You need special filters (glasses).
Green / Magenta Stereo You need special filters (glasses).
Red / Cyan Stereo You need special filters (glasses).
Vertical Interlaced Stereo To use this stereo mode, you need a special 

stereoscopic display; for example, Ecomo 4D
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Auto-open all AutoCAD documents
Prevents QuadroView from opening all documents (opened in AutoCAD).

Default
Restores all values to their standard settings.

Preferences: AutoCAD Tools

Figure 8.3 Preferences: AutoCAD Tools

Menu View > Preferences > AutoCAD Tools
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Table 8.3  Preferences: AutoCAD Tools 
Option Description
Ignore entities of 
type �.

It may make sense for your models to mask off certain entity types. This 
set of check boxes allows you to filter the basic entity types used by 
AutoCAD. Depending on your version of AutoCAD, some boxes may be 
grayed.
Note: Entity selection is another method you can use to exclude parts of 
your model from the rendering. Both methods may be combined.

Deviation QuadroView can adapt the precision of the rendered model to your 
requirements. The deviation defines the maximum allowed error for 
rendering curved areas on the screen.
The deviation has a significant impact on the amount of geometry data to 
be rendered and thus the performance, in terms of memory consumption 
and speed. Use it carefully! The smoother the deviation, the lower the 
rendering performance.

Coordinate System This group panel gives you control over the coordinate system helpers, 3D 
representations of the AutoCAD world coordinate system (WCS), and 
user coordinate system (UCS) that are displayed in the Viewer. Each 
coordinate system can be displayed by a colored icon at the Origin, a grid 
plane from Origin to Limits, or both.
The grid density is adjustable (drawing units). If UCS is identical to WCS, 
the UCS display is suppressed.

Show AutoCAD 
Wireframe

You can choose from AutoCAD Wireframe mode (Isolines) or 
QuadroView Wireframe (Mesh).
AutoCAD Wireframe has an impact on the amount of geometry data to be 
rendered. This, in turn, has a significant impact on the rendering and 
overall system performance. Therefore, we strongly recommend you use 
the QuadroView Wireframe mode!

Default The Default button restores all values to their standard settings.
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Preferences: AutoCAD Link

Figure 8.4 shows the AutoCAD Link dialog box.

Model Update
These options control how the Viewer handles changes in your drawing.

Camera Update
These options can be used to update the AutoCAD View in the active viewport 
within the Viewer.

Table 8.4 AutoCAD Link: Model Update Options
Option Description
Manual The rendered model is not automatically updated. Invoke the commands 

NVA or NVS to send a snapshot of your drawing or parts of it to the 
viewer.

Auto, QuadroView 
group

All drawing elements found in the NVIDIA QuadroView group are 
automatically sent to the viewer and kept updated, which allows you to 
keep your render selection across AutoCAD sessions as the group is saved 
in the drawing file. 
Add New Entities to the Group: Activate this option if you want to add 
new entities to the group.

Auto (All) All drawing elements are automatically sent to the viewer and kept 
updated.

Auto (Active Part) Note: This update mode works only with Mechanical Desktop.

The part that is currently active is sent to the Viewer and kept updated.

Table 8.5  AutoCAD Link: Camera Update Options
Option Description
Immediate Every view change is immediately sent to AutoCAD.
Delayed by .. sec View changes are sent to AutoCAD whenever there is no change for the 

specified amount of time.
On command This is the default setting. Views are not automatically sent to AutoCAD. 

You have to click the icon from the toolbar to force an update.

Menu View > Preferences > AutoCAD Link
N V I D I A  C o r p o r a t i o n C O N F I D E N T I A L  80



C H A P T E R  8 Q u a d r o V i e w  P r e f e r e n c e s  S e t t i n g s

BKNVRelQV_oem.book  Page 81  Friday, April 19, 2002  2:43 AM
Figure 8.4 Preferences: AutoCAD Link

Window Position

Standard
Displays your NVIDIA QuadroView viewer window underneath AutoCAD 
when you have both QuadroView and AutoCAD open.

On Top of AutoCAD
Automatically displays your NVIDIA QuadroView viewer window on top of 
AutoCAD when you have both QuadroView and AutoCAD open.

Other
NVIDIA QuadroView allows you to synchronize the background color of the 
current document with AutoCAD. To use this feature, make sure that the check 
box named �Synchronize with AutoCAD Background Color� is checked.
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Configure Demand Load
This option opens the Demand Load Configuration dialog box with the added 
convenience of accessibility from within QuadroView.

See �Loading QuadroView in AutoCAD� on page 38 for details on completing 
this dialog box.

Default
The Default button restores all values to their standard settings.
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C H A P T E R

9
QUADROVIEW AND AUTOCAD

This chapter contains the following major topics:

� �QuadroView Commands in AutoCAD� on page 84

� �QuadroView Toolbar Options in AutoCAD� on page 86

QuadroView Commands in AutoCAD
The NVIDIA QuadroView ARX modules add several commands to the 
AutoCAD command set as listed in Table 9.1. You can create scripts and LISP 
programs with these commands to automate common actions.

You can also access several of these commands through QuadroView toolbars 
in AutoCAD. See �QuadroView Toolbar Options in AutoCAD� on page 86. 
Table 9.1 NVIDIA QuadroView Commands in AutoCAD

QuadroView Command Description

NVDA_NVSTART Starts the Viewer; the ARX module must be loaded.

NVDA_NVSTOP Unloads the Viewer; the ARX module remains loaded.

NVDA_NVVERSION Shows the version of the ARX module.

NVDA_NVCFGDEMANDLOAD Sets the startup functionality of QuadroView to 
�automatic start� or �start on command�.

NVDA_NVALL Switches �Model Update� on page 80 mode to �Auto, 
all�.

NVDA_NVSEL Switches �Model Update� on page 80 mode to �Auto, 
group QuadroView� and clears �Add new entities to 
group�
N V I D I A  C o r p o r a t i o n 84



C H A P T E R  9 Q u a d r o V i e w  A n d  A u t o C A D

BKNVRelQV_oem.book  Page 85  Friday, April 19, 2002  2:43 AM
QuadroView Command Description

NVDA_NVSELADD Switches �Model Update� on page 80 mode to �Auto, 
group QuadroView� and sets �Add new entities to 
group�.

NVDA_NVMANUAL Switches �Model Update� on page 80 mode to 
�Manual�.

NVDA_NVACTPART When running with Mechanical Desktop, the �Model 
Update� on page 80 mode is switched to �Auto, active 
part�.

NVDA_NVA Transfers the complete drawing to the Viewer.

NVDA_NVS Transfers the selected part of the drawing to the 
Viewer.

NVDA_NVVIEW Transfers the current AutoCAD view to the Viewer.

NVDA_NVMIN Minimizes the Viewer window.

NVDA_NVMAX Maximizes the Viewer window.

NVDA_NVNORM Restores the normal size of the Viewer window.

NVDA_NVFRONT Brings the Viewer window to the front.

NVDA_NVMINDOC Minimizes the current document in the Viewer.

NVDA_NVMAXDOC Maximizes the current document in the Viewer.

NVDA_NVNORMDOC Restores the normal size of the current document in 
the Viewer.

NVDA_NVFRONTDOC Brings the current document in the Viewer to the 
front.

NVDA_NVMENULOAD Opens the QuadroView icon bar in the AutoCAD 
window.

NVDA_NVROTPT Sets the rotation point.

NVDA_NVROTATE Performs a 3D rotation about the rotation point by a 
given axis and angle.

NVDA_NVZOOM Performs a zoom.

NVDA_NVPAN Moves the camera parallel to the current view plane.

NVDA_NVWIREFRAME Switches the Renderer to Wireframe.

NVDA_NVHIDDENLINE Switches the Renderer to Hiddenline.

NVDA_NVFLAT Switches the Renderer to Flat Shaded.

NVDA_NVGOURAUD Switches the Renderer to Gouraud Shaded.

NVDA_NVPREFERENCES Opens the QuadroView Preferences dialog box.

NVDA_NVLINKDOC In QuadroView, this command creates a link to the 
AutoCAD current document.

Table 9.1 NVIDIA QuadroView Commands in AutoCAD (continued)
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QuadroView Toolbar Options in AutoCAD
The NVIDIA QuadroView toolbar (Figure 9.1) is loaded when you run 
AutoCAD for the first time after setting up QuadroView to run within 
AutoCAD. 

Note: The options provided in this QuadroView toolbar within AutoCAD 
provide the same functionality as those toolbars (see �QuadroView 
Toolbars� on page 48) inside the NVIDIA QuadroView viewer; for 
convenience, these toolbar options are provided separately through 
AutoCAD.

For a complete list of additional AutoCAD commands, see �QuadroView 
Commands in AutoCAD� on page 84.

NVIDIA QuadroView Toolbar
After setting up QuadroView to run within AutoCAD, the first time you run 
AutoCAD, following these steps to enable the NVIDIA QuadroView toolbar:

1 From AutoCAD, click View > Toolbars. The Toolbars panel of the 
Customize window appears.

2 From the �Menu Group� box, click QuadroView. In the Toolbars section on 
the left of the window, you will see the following options:

QuadroView Command Description

NVDA_NVUPDBKGCOLOR If the background color is in Sync mode, this 
command updates the background color of the 
document in the QuadroView viewer that corresponds 
to the current document in AutoCAD. To synchronize 
the background color, see �Preferences: AutoCAD 
Link� on page 80.

NVDA_NVSELANIMPATHS Selects Camera Path and LookAt Path for an 
animation in the Viewer.

NVDA_NVSELLOOKATPATH Selects only a LookAt Path. A Camera Path must 
already exist.

NVDA_NVTOGCAMPATH Toggles visibility of the spline that defines the Camera 
Path.

NVDA_NVTOGLOOKATPATH Toggles visibility of spline that defines the LookAt 
Path.

NVDA_NVDELCAMPATH Deletes animation data for Camera Path and LookAt 
Path.

NVDA_NVDELLOOKATPATH Deletes animation data for LookAt Path.

Table 9.1 NVIDIA QuadroView Commands in AutoCAD (continued)
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� Animation

� NVIDIA QuadroView

� Update Modes

� Window position

3 Click the NVIDIA QuadroView toolbar check box; this is the main 
QuadroView toolbar (Figure 9.2) from which you can access the �fly-out� 
options for Animation, UpdateModes, and Window position. 

Note: If you want to have access to these �fly-out� options as separate 
toolbars, you can also check these other options in the Toolbars 
section.

4 Click Close when you�re done.

Figure 9.1 QuadroView Toolbar in AutoCAD

Table 9.2  QuadroView Options in AutoCAD
Option Description

 NVALL Switches �Model Update� on page 80 mode to �Auto, all�. 
When you click the bottom right arrow, a fly-out list of 
Update Mode icons (options) appear. See �Update Modes 
Options� on page 88 for a description of these options.

 NVVIEW Sends current camera settings to the Viewer.

 NVA Sends entire model to the Viewer.

 NVS Sends selection to the Viewer.

 NVSTART Loads QuadroView.

 NVSTOP Closes QuadroView (ARX module remains loaded).

 NVLINKDOC Creates a link to QuadroView for the current document. When 
you click the bottom right arrow, a fly-out list of Update 
Mode icons (options) appear. See �Window Position Options� 
on page 88 for a description of these options.

 NVSELANIMPATHS Use this option to define the spline for the Camera Path and 
the spline (if any) for the LookAt Path. When you click the 
bottom right arrow, a fly-out list of Update Mode icons 
(options) appear. See �Animation Options� on page 89 for a 
description of these options.

 NVPREFERENCES Opens the QuadroView Preferences dialog box.
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Update Modes Options
Figure 9.2 QuadroView Update Modes in AutoCAD

The options in Table 9.3 are also available from inside the QuadroView viewer; 
see �Model Update� on page 80.

Window Position Options
Figure 9.3 QuadroView Window Position Toolbar in AutoCAD

Table 9.3 QuadroView Update Modes Options in AutoCAD
Option Description

 NVALL Switches Model Update mode to �Auto, all�.
 NVSEL Switches Model Update mode to �Auto, group 

NVIDIA QuadroView� and clears �Add new 
entities to group�.

 NVSELADD Switches Model Update mode to �Auto, group 
NVIDIA QuadroView� and sets �Add new entities 
to group�.

 NVACTPART When running with Mechanical Desktop, the Model 
Update mode is switched to �Auto, active part�.

 NVMANUAL  Switches Model Update mode to �Manual�.

Table 9.4 QuadroView Window Position Options in AutoCAD
Options Description

 NVLINKDOC Creates a link to QuadroView for the current document.
 NVNORM Switches the QuadroView main window to front.
 NVDOCINFRONT Switches corresponding QuadroView document 

window to front.
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Animation Options
Figure 9.4 QuadroView Animation Toolbar in AutoCAD

In AutoCAD, you can define, hide, and remove the splines for an animation 
inside the Viewer by using the options in the toolbar.

The options in Table 9.5 are also available from inside the QuadroView viewer; 
see �Animation Toolbar� on page 50. 

Table 9.5 QuadroView Animation Options in AutoCAD
Option Description

 NVSELANIMPATHS Use this option to define the spline for the Camera Path 
and the spline (if any) for the LookAt Path. 
� When you start the command, you are asked to 

select a spline to be the Camera Path. 
� If a Camera Path already exists, you can skip 

selecting the Camera Path and keep the current one. 
� You can define the LookAt Path in the same way. 
� If you do not want a LookAt Path, right click or 

press ESC or ENTER to end the command. 

Note: If Animation Paths were already defined, the 
animation data will be deleted and the new paths will 
define an animation with default settings.

 NVSELLOOKATPATH Defines a path to be the LookAt Path. A Camera Path 
must already exist. Use this command to select only a 
LookAt Path without changing the Camera Path.

 NVTOGCAMPATH Toggles visibility of the Camera Path.
 NVTOGLOOKATPATH Toggles visibility of the LookAt Path. Use this 

command to switch the Camera Path (if any), visible or 
invisible. Use this command to switch the LookAt Path 
(if any), visible or invisible

 NVDELCAMPATH Deletes animation data for the Camera and LookAt 
Path.

 NVDELLOOKATPATH Deletes animation data for the LookAt Path.
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